如果网站数据是从别的CMS转过来的或者之前手动改动过phpMyAdmin中MySQL的数据表id,在后续增加文章的时候有可能会提示主键获取失败。

这主要是因为数据表id创建失败。

修复方法

首先需要登录phpMyAdmin中。在进行本操作之前,请务必备份数据库。

1.找到要改动的数据表结构,选中字段后,点击主键。
1.png

2.点击修改。

2.png

3.选中AI这个选项后提交。

3.png

4.最后达到的效果如下:

4.png

修改id序号的方法

5.png